Back to overview
Degraded
Issue with our upstream provider
Oct 20 at 10:00am EDT
Affected services
edu.reforge.com platform
Resolved
Oct 20 at 06:00pm EDT
Functionality has been restored to the learning platform.
Affected services
Updated
Oct 20 at 04:31pm EDT
We are now seeing recovery regarding latency and access errors. We will continue to monitor the situation.
Affected services
Created
Oct 20 at 10:00am EDT
Our upstream provider, AWS, is experiencing degraded performance for the us-east-1 region. This is causing significant latency when loading content within our learning platform.
Affected services